Ultimate Facebook: Turn off comments on pages

Hello-

how can I turn off facebook comments on pages, and leave them on for posts?

thanks

    Philip John

    Hiya!

    Ultimate Facebook simply follows the WordPress settings for comments.

    So, to turn comments of on pages, go into the edit screen and click on Screen Options in the top-right. Then check the Discussion box:

    Then, a box will appear below the editor window called "Discussion" and you just need to ensure Allow comments is unchecked:

    Thanks!
    Phil

    jrblewis
    • 9
    • #10,916

    thanks Phil,

    but this doesnt seem to be the case with me. the discussion box doesnt show up when editing pages, and it isnt an option to display on the screen options tab.

    I am using the default Twenty Eleven 1.2 theme. Could this be the issue?

    thanks

    Philip John

    Are you using the most recent version of WordPress (v3.2.1) too?

    Phil

    Philip John

    Okay, can you try disabling all plugins and reverting to the default theme and see if that screen options tab includes the Discussion option please?

    It *should* be there so something must be removing it....

    Phil

    jrblewis
    • 9
    • #10,916

    Phil-

    I havent had time to troubleshoot that bit. BUT, I did:
    1. go to "all pages"
    2. selected all pages and did "bulk edit"
    3. selected comments "do not allow" and then saved

    still nothing. any other suggestions ? Im a bit on a time crunch because the site needs to launch soon. I may try to hide it on pages via CSS

    Philip John

    Yep, it sounds like your theme is calling the relevant hook even though you've told it not to.

    Switching to the default theme will help to confirm that, or rule it out...

    Phil

    Mason

    Hiya,

    Just checking if it was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, could you let us know by re-opening this topic, and we'll get onto it and helping you out asap!
    Otherwise, happy days, glad you got it sorted :)

    Thanks!

    Gabriel
    • Elite
    • 322
    • #283

    Hi! I'm having the same problem, but in my case I only use the facebook comments box, not the wp comments system. I was having trouble trying to override the wp comments with the facebook comments box (more info here: http://premium.wpmudev.org/forums/topic/ultimate-facebook-isnt-overriding-wordpress-comments#post-288999 ) and, when almost everything seemed to be working fine, I checked my "Contact" page and the facebook comments box was there.

    I did exactly as Phil said in his first answer on this topic, went to my "Contact" page to edit it, opened the Screen Options, etc., but the facebook comments box is still there. I'm using a plugin called Disable Comments, like a guy from WPMU DEV staff said, to override the wp comments (check the link I gave for more info on it); I had to deactivate this plugin to be able to follow Phil's instructions. If I have Disable Comments deactivated, there are no comments box on my Contact page (which is what I want), but then I have the wp comments system on my posts, which I don't want.

    How can I solve this?

    Thanks!

    Gabriel
    • Elite
    • 322
    • #283

    UPDATE:
    I was able to remove the wordpress comments box without having to use the Disable Comments plugin, I just changed my wp settings to not allow people comment on new posts, then deleted the only post I had and created a post equal to the one I deleted (I've created this single post at my site exactly to test things before I start posting for real). Actually the Disable Comments plugin is only useful if the site already has a lot of posts, because it allows to remove the wp comments box from old posts, while the wp settings only allow new posts to have the comments box disabled.

    That said, here's my problem: when I check the option to "Override Wordpress discussion settings" at Ultimate Facebook, I have the facebook box on posts (which I want) and on pages (which I don't want); if I don't check that option I have no facebook comments box at all (neither on my posts, nor on my pages).

    All I want is to remove the facebook comments box from my pages. How do I do that?

    Thanks again!

    Gabriel
    • Elite
    • 322
    • #283

    I'm marking this topic as resolved because I don't have more time for troubleshooting. If I need any help in the future, I'll just re-open it.

    Thanks!

    Mason

    Hiya,

    that's really weird though. I understand you've closed this, but you shouldn't have commenting on pages, regardless. Do you have the comments turned off within WordPress for these pages?

    Let us know if you want to dig into this further. Thanks!

    Gabriel
    • Elite
    • 322
    • #283

    Hi! Yes, I have disabled comments for these pages, and I also have selected the option to override comments at Ultimate Facebook. But don't worry, man. Like I said, I've marked my topics as resolved because I don't have more time to spend with troubleshooting; actually, the problems I have now are no big deal, nothing that can prejudice my site, to be honest, these problems are more related to aesthetic details.

    Thank you very much for your interest in helping me!

Join 366163 happy members

Get access to our entire collection of epic plugins, astonishing themes & genius support

Become a member